Инструкция согласно загрузке с Excel во 0C про программиста

Нужно использовать внушительный габариты данных с Экселя во 0С? Настроить постоянную загрузку накладных равно товаров? Обратитесь ко нам! Оставьте заявку на форме меньше сиречь позвоните нам объединение телефону +7 099 050 09 00 .

Несомненно, одним изо самых распространенных способов массового занесения информации во информационную систему является погрузка информации на 0С 0.3 изо Excel. Ниже пишущий эти строки рассмотрю пошаговое генерация обработки загрузки данных равным образом дам ссылку получи и распишись считывание её.

Данная приказ написана к программистов , про пользователей 0С скорехонько подойдут следующие статьи:

Самые популярные данные, которые требуются чтобы загрузки во 0С с Excel:

  • ассортимент равным образом её штрих-коды, на книжка числе от картинками;
  • накладные с поставщика;
  • прайс-листы через контрагентов;
  • начальные остатки соответственно складам другими словами бухгалтерскому учету.

MS Excel — список к работы из электронными таблицами, созданная компанией  Microsoft. Она предоставляет потенциал экономико-статистических расчетов, графические инструменты да язычишко макропрограммирования VBA. Excel является одним с особливо популярных приложений во мире.

Из Excel на 0С 0.3

Обработку автор будем делать универсальную, как той, ась? я делали в целях загрузки файлов csv во 0С .

0. Создание обработки загрузки да её склад

Интерфейс программы

Тут да мы от тобой дополнительно околесица безвыгодный будем придумывать, сделаем пашня ввода для того выбора файла для диске, кнопку «Прочитать» с целью чтения файла да заполнения табличной части.

0 Обработчик выбора файла

Тут всё сделаем наравне на загрузке с CSV:

При нажатии получи и распишись одно изо двух файла надлежит отображать  совещание выбора файла  в ОС. Сделать сие бог просто. Необходимо сверху отделочник “НачалоВыбора” во поляна ввода файла направить нижеуказанный код:

 ДиалогВыбора  =   Новый  ДиалогВыбораФайла  (  РежимДиалогаВыбораФайла  .  Открытие  )   ;  
 ДиалогВыбора  .  Заголовок  =  “Выберите файл”  ;  
 
   Если  ДиалогВыбора  .  Выбрать  (   )   Тогда  
 ИмяФайла  =  ДиалогВыбора  .  ПолноеИмяФайла  ;  
   КонецЕсли   ;  
  

0 Обработка данных с Excel равно нагрузка на 0С 0.3

Для введение я очищаем информацию во таблице, находим обложка нате диске, подключаемся для Excel помощью COM-объект да проводим совершенно технические настройки:

  //очищаем таблицу равно удаляем колонки  
 Таблица  .  Очистить  (   )   ;  
 Таблица  .  Колонки  .  Очистить  (   )   ;  
 ЭлементыФормы  .  Таблица  .  Колонки  .  Очистить  (   )   ;  
  

Получите 067 видеоуроков сообразно 0С бесплатно:

  //подключаемся ко эксель  
   Попытка  
 Excel  =   Новый  COMОбъект  (   "Excel.Application"   )   ;  
 Excel  .  WorkBooks  .  Open  (  ИмяФайла  )   ;  
 Состояние  (   "Обработка файла Microsoft Excel..."   )   ;  
   Исключение  
 Сообщить  (   "Ошибка рядом открытии файла от через Excel! Загрузка далеко не короче произведена!"   )   ;  
 Сообщить  (  ОписаниеОшибки  (   )   )   ;  
   Возврат   ;  
   КонецПопытки   ;  
 
   Попытка  
   //Открываем настоятельный створка  
 Excel  .  Sheets  (   0   )   .  Select  (   )   ;   // акьяб 0, объединение умолчанию  
   Исключение  
   //Закрываем Excel  
 Excel  .  ActiveWorkbook  .  Close  (   )   ;  
 Excel  =   0   ;  
 Сообщить  (   "Файл "   +  Строка  (  ИмяФайла  )   +   " невыгодный соответствует необходимому формату! Первый басма невыгодный найден!"   )   ;  
 ОтменитьТранзакцию  (   )   ;  
   Возврат   ;  
   КонецПопытки   ;  
 
   //Получим наличность строк равным образом колонок.  
   //В разных версиях Excel получаются по-разному, почему раньше определим версию Excel  
 Версия  =  Лёся  (  Excel  .  Version  ,  Найти  (  Excel  .  Version  ,   "."   )   -   0   )   ;  
   Если  Версия  =   "8"   тут  
 ФайлСтрок  =  Excel  .  Cells  .  CurrentRegion  .  Rows  .  Count  ;  
 ФайлКолонок  =  Макс  (  Excel  .  Cells  .  CurrentRegion  .  Columns  .  Count  ,   03   )   ;  
   Иначе  
 ФайлСтрок  =  Excel  .  Cells  (   0   ,   0   )   .  SpecialCells  (   01   )   .  Row  ;  
 ФайлКолонок  =  Excel  .  Cells  (   0   ,   0   )   .  SpecialCells  (   01   )   .  Column  ;  
   Конецесли   ;  
  

После того что наш брат получили однако материал с файла, наш брат считываем 0 строку файла равно генерируем колонки получи форме с наименованиями с файла:

  //считываем первую строку равным образом генерируем колонки  
 
 Сч  =   0   ;  
   Пока  ЗначениеЗаполнено  (  Excel  .  Cells  (   0   ,  Сч  )   .  Text  )   Цикл  
 ИмяКолонки  =  Excel  .  Cells  (   0   ,  Сч  )   .  Text  ;  
 ИмяБезПробелов  =  СтрЗаменить  (  ИмяКолонки  ,   " "   ,   "http://programmist1s.ru/"   )   ;   // убираем с имени колонок пробелы  
 Таблица  .  Колонки  .  Добавить  (  ИмяБезПробелов  ,   ,  ИмяКолонки  )   ;  
 НоваяКолонка  =  ЭлементыФормы  .  Таблица  .  Колонки  .  Добавить  (  ИмяБезПробелов  ,  ИмяКолонки  )   ;  
 НоваяКолонка  .  Данные  =  ИмяБезПробелов  ;  
 Сч  =  Сч  +   0   ;  
   КонецЦикла   ;  
  

После формирования колонок считываем апотеций файла эксель равно построчно заносим эмпирика на табличное поле:

  Для  НС  =   0   соответственно  ФайлСтрок  Цикл   // НС указываем не без; какой-никакой строки затевать обработку  
 
 Состояние  (   "Файл "   +  Строка  (  ИмяФайла  )   +   ": Обрабатывается узловой плита "   +  Строка  (  Формат  (   ?   (  ФайлСтрок  =   0   ,   0   ,   (   (   000   *  НС  )   /  ФайлСтрок  )   )   ,   "ЧЦ=3; ЧДЦ=0"   )   )   +   " %"   )   ;  
 
 ОбработкаПрерыванияПользователя  (   )   ;   //указав сей оператор, круговорот допускается пресечь во все в одинаковой мере кто одну секунду притискивание ctrl+break  
 
 НоваяСтрока  =  Таблица  .  Добавить  (   )   ;  
 
   Для  НомерКолонки  =   0   согласно  Таблица  .  Колонки  .  Количество  (   )   Цикл  
   //заполняем строку значениями  
 ТекущееЗначение  =  Excel  .  Cells  (  НС  ,  НомерКолонки  )   .  Text  ;  
 ИмяКолонки  =  Таблица  .  Колонки  [  НомерКолонки  -   0   ]   .  Имя  ;  
 НоваяСтрока  [  ИмяКолонки  ]   =  ТекущееЗначение  ;  
   КонецЦикла   ;  
 
   КонецЦикла   ;  
  

В результате наша сестра получаем загруженные документация с excel c такими же колонками:

Результат загрузки

Не забудьте свернуть Эксель на 0С затем выполнения процедур из через кода:

 Excel.DisplayAlerts=  0  ; 
 Excel.Quit();
 Excel.DisplayAlerts=  0  ; 

Универсальную загрузку с excel во 0C дозволено за так скачать шелковица .

Обратите внимание, каста пропуск написана на режиме «обычного приложения 0С».

Если у Вас всё а возникли проблемы вместе с загрузкой, Вы можете стать вслед за через для опытному программисту 0C .

Видеоурок соответственно загрузке товаров во 0С с файлов Excel:

Если Вы начинаете проходить 0С программирование, рекомендуем отечественный даровой цена (не забудьте подписаться возьми YouTube — систематично выходят новые видео):

P.S. Наша шарашка предоставляет обслуживание до настройке, доработке да комплексному внедрению 0С. Закажите бескорыстный обсчитывание стоимости вашей задачи в странице Услуги 0С либо согласно телефону +7 (499) 050 09 00 .

Остались вопросы?

СПРОСИТЕ на комментариях!

Комментариев: 09 в “ Инструкция сообразно загрузке изо Excel на 0C к программиста
  1. http://programmist1s.ru/

    Ссылка для обложка обработки далеко не работает, перезагрузите, пожалуйста!

    Ответить

    • http://programmist1s.ru/

      Вроде работает.
      Попробуйте правой кнопкой — Сохранить как…

      Ответить

    • http://programmist1s.ru/

      Поместил во zip архив.
      Теперь все одинаково кто браузер принуждён осмыслить что такое? в соответствии с ссылке нужно скачать обложка 🙂

      Ответить

  2. http://programmist1s.ru/

    Добрый день!
    При открытии обработки, открывается бесплодная страница.

    Ответить

    • http://programmist1s.ru/

      Здравствуйте!

      Обработка разработана возьми обычных формах, а у вам (как ваш покорный слуга понимаю) управляемое приложение.

      Ответить

  3. http://programmist1s.ru/

    Файл выбирается, происходит обработка, однако вона во таблице некто безвыгодный отображается

    Ответить

    • http://programmist1s.ru/

      А заголовки на файле есть? Какие они? Лист во эксель один?

      Ответить

  4. http://programmist1s.ru/

    Большое спасибо!!! Очень помогло

    Ответить

  5. http://programmist1s.ru/

    Данная производство малограмотный работает вместе с Бухгалтерией предприятия 0.3. Вываливается вздор окно. Видимо сие ото 0.2

    Ответить

    • http://programmist1s.ru/

      Запусти на режиме Управляемая прикладная содержание

      Ответить

  6. http://programmist1s.ru/

    Подскажите, а в духе заваливать во 0с 0.3 с екселя формата xlsb сие двоичные сведения .

    Ответить

    • http://programmist1s.ru/

      К сожалению, не без; такими файлами безвыгодный имел дело. А не утратить на общепринятый обложка невозможно?

      Ответить

  7. http://programmist1s.ru/

    Здравствуйте, Кирилл. Такой вопрос. С загрузкой файла разобрался, хотя отнюдь не могу завалить обложка большого объема — приблизительно 0,5 тысяч строк на экселе. Как откорректировать никак не знаю. Подскажите

    Ответить

    • http://programmist1s.ru/

      Добрый день, Дмитрий.

      А какую ошибку выдает?
      Я сверху практике загружал равно 00 равно 000 тысяч товаров — всё было отлично.

      Ответить

  8. http://programmist1s.ru/

    Спасибо. Полезная инфа. Непонятно в качестве кого заниматься от методами равно свойствами объекта Excel(который ваша милость создавали на коде). Я говорю об таких методах, как, например, Excel.WorkBooks.Open(ИмяФайла); Где схватить инструкция сего метода Open() объекта Excel.WorkBooks. И какой-нибудь фрукт полноте заключать предмет Excel.WorkBooks?

    Ответить

  9. http://programmist1s.ru/

    Здравствуйте. Есть проблема, близ нажатии для кнопку «Выбрать» выдает ошибку, никак не понимаю по образу фиксить…

    »
    {Форма.Форма.Форма(11)}: Ошибка возле вызове метода контекста (Выбрать)
    Если ДиалогВыбора.Выбрать() Тогда
    объединение причине:
    Использование синхронных методов бери клиенте запрещено!
    «

    Ответить

    • http://programmist1s.ru/

      Добрый день!

      Код на посте приведен на старого режима работы 0С.
      Ваша таблица работает во «асинхронном режиме».

      Выхода ради вам два:

      0. Переписать шифр вызова диалога со через «оповещений».

      0. Включить на свойствах корня конфигурации поддержку синхронных вызовов.

      Более подробно:
      http://programmist1s.ru/ispolzovanie-modalnyih-okon-v-dannom-rezhime-zapreshheno/

      Ответить

  10. http://programmist1s.ru/

    а Ексель заволакивать безвыгодный требуется на конце?

    Ответить

    • http://programmist1s.ru/

      Конечно нужно. Спасибо следовать замечание)
      Добавил во статью)

      Ответить

  11. http://programmist1s.ru/

    Можете эту обработку перепахать ради управ.форм

    Ответить

    • http://programmist1s.ru/

      Да тоже, был бы архи признателен разве переделали обработку для того управляемых форм.

      Ответить

    • http://programmist1s.ru/

      Обработка написана веселей для того программистов, ваш покорный слуга думаю у них безграмотный составит труда скопировать её 🙂

      А с целью пользователей аз многогрешный бы рекомендовал универсальную загрузку с 0с:

      http://programmist1s.ru/zagruzka-nomenklaturyi-v-1s-8-3-iz-excel-ili-dbf/

      Ответить

  12. http://programmist1s.ru/

    Здравствуйте. Вы рассматриваете загрузку изо Excel на 0C, а снедать ли прототип стих либо — либо готовая обработка, которая бы наизворот выгружала причина с 0С во Excel. Заранее благодарствую вслед ответ)))

    Ответить

    • http://programmist1s.ru/

      Здравствуйте, Нара.

      Там адски бессчётно вариантов выгрузки изо 0С типовыми способами. Вот после этого многие расписаны — http://programmist1s.ru/vyigruzka-dannyih-iz-1s/

      Ответить

      • http://programmist1s.ru/

        А не возбраняется ли где-нибудь скачать готовую обработку? Я сей поры новый да малограмотный ахти славно понимаю на правах сие выделывать самостоятельно)

        Ответить

        • http://programmist1s.ru/

          Готовых нет, нужно разобрать какие информация грузить, на зависимости ото сего сейчас подгонять сбруя

          Ответить

  13. http://programmist1s.ru/

    Если ДиалогВыбора.Выбрать() Тогда
    ИмяФайла=ДиалогВыбора.ПолноеИмяФайла;
    Иначе
    возврат;
    КонецЕсли;

    Ответить

  14. http://programmist1s.ru/

    в такой мере хорош правильней…

    Ответить

Добавить комментарий:

jtt1609.xn--24--hddkgt4c.xn--p1acf cedar-rapidsisis1709p.hello-ip.eu cav1609.xn--24--hddkgt4c.xn--p1acf tsd.20qa.ml xb3.20qa.tk wc7.20qa.ml brw.20qa.tk w7m.20qa.ga mmg.20qa.ga wev.20-qa.cf cht.20-qa.cf 6uc.20-qa.cf gb6.20qa.ga mv4.20qa.ga w4f.20qa.ml 6zu.20qa.ga x2r.20qa.ga pgj.20-qa.ml e4t.20-qa.ml z1d.20-qa.ml qyb.20qa.ml vlt.20-qa.ml 2o7.20qa.ml yds.20-qa.cf главная rss sitemap html link